Mensagens

A mostrar mensagens de Março, 2012

EXCEL 2007 - Como utilizar a função FREQUÊNCIA (How to use FREQUENCY Function)

Imagem
Como utilizar a função FREQUÊNCIA
Para se calcular o número de ocorrências de valores num conjunto de intervalos, usamos a função FREQUÊNCIA, que é uma função matriz. Como todas as funções deste tipo, A FREQUÊNCIA opera a partir de uma matriz de dados. Esta função, porém, precisa de outra variável: uma matriz de bins.
A matriz de dados é uma tabela de dados onde listamos os resultados pretendidos (ver Fig. A - DATABASE). A matriz de bins é a tabela de categorias ou de intervalos aos quais os resultados obtidos são associados (ver Fig. A - tabelas PESO e ALTURA).

EXCEL 2007 - SOMAR VALORES COM CRITÉRIOS MÚLTIPLOS (SUMIF WITH MULTIPLE CRITERIA)

Imagem
Na mensagem anterior apresentei um modelo de filtragem de dados com recurso a uma função UDF. Nesse mesmo modelo utilizei uma função para somar os valores constantes da tabela de acordo com vários critérios. Para executar este procedimento, existem várias alternativas utilizando as funções SOMARPRODUTO ou SOMA.SE.S: A célula com fundo rosa tem a seguinte fórmula: "=SOMARPRODUTO((BaseDados!$A$2:$A$5000=C$1)*(BaseDados!$C$2:$C$5000=$A4)*(BaseDados!$E$2:$E$5000))"A célula com fundo verde tem a seguinte fórmula: "=SOMARPRODUTO(--(BaseDados!$A$2:$A$5000=D$1);--(BaseDados!$C$2:$C$5000=$A5);--(BaseDados!$E$2:$E$5000))"Por fim, a célula com fundo laranja tem a fórmula: "=SOMA.SE.S(BaseDados!$E$2:$E$5000;BaseDados!$A$2:$A$5000;E$1;BaseDados!$C$2:$C$5000;$A6)". Todas estas possibilidades permitem chegar ao mesmo resultado. A diferença está apenas na rapidez de cálculo que o Excel executa. Ora, se em pequenas tabelas essa diferença é praticamente inexistente, já qua…