sexta-feira, 12 de agosto de 2016

Problema Resolvido - DETERMINAR A DURAÇÃO DE UMA TAREFA (Solved Problem - How to determine an activity duration)

Um leitor (Obrigado Denis) precisou de ajuda para determinar a data de conclusão da montagem de uma máquina, sabendo que:
A blog reader (Thanks Denis) asked me for help in determining the date of completion of the assembly of a machine, knowing that:

A duração da montagem é de 30 horas de trabalho.
The duration of the assembling is 30 working hours.

O turno regular é de 8:48 horas, das 8:00 às 17:48, incluindo o intervalo de 1:00 para almoço.
Regular shift is 8:48 hours, from 8:00 to 17:48, including the 1:00 for lunch.

A data de início da montagem é 21/09/2014 10:00.
The start date of the assembly is 21/09/2014 10:00.

Passemos então à demonstração:
A distribuição das 30 horas seria efectuada da seguinte forma:
The 30 hours distribution would be performed as follows:








Início Turno
30:00
Almoço
Fim Turno


21-09-2014 10:00
06:48
01:00
21-09-2014 17:48


22-09-2014 08:00
08:48
01:00
22-09-2014 17:48


23-09-2014 08:00
08:48
01:00
23-09-2014 17:48


24-09-2014 08:00
05:36

24-09-2014 13:36








A montagem da máquina terminaria no dia 24 de Setembro de 2014, às 13:36.
The machine assembly end on September 24, 2014, at 13:36.

Método de cálculo:
Method of calculation:

Em primeiro lugar, vamos converter “8:48” (duração do turno) em valor decimal, aplicando uma rega de três – Se “8:00” é igual a 8, “8:48” será igual a “x”
First, we convert "8:48" (shift duration) in decimal value by applying a simple rule of three - If "8:00" is equal to 8 then "8:48" is equal to "x"

Fórmula - =”8:48” / 8 x “8:00” – a que corresponde o resultado de 8,8
Formula - = "8:48" / 8 x "8:00" - which corresponds to the result of 8.8

Construindo a fórmula:
Building formula:


A
B
C
1
30:00
21 set 2014 10:00
24 set 2014 13:36
2



3




Fórmula em C1 - =B1+(INT(A1*24/8,8)+RESTO(A1*24;8,8)/24)

Formula em C1 - =B1+(INT(A1*24/8.8)+MOD(A1*24,8.8)/24)

segunda-feira, 1 de agosto de 2016

CALCULAR TEMPO ENTRE LOTES DE PRODUÇÃO (Calculating Time Between Production Batches)

Este problema foi apresentado por um leitor e seguidor (Obrigado Maxwell)

This problem was presented by a reader and follower (Thanks Maxwell)

Trata-se de calcular o atraso entre lotes de produção, tendo em consideração um valor tempo definido entre lotes, e realçando os valores tempo entre lotes superiores ao valor pré-definido (neste exemplo - 02:35)

This is to calculate the delay between production batches , considering a set time value between lots, and highlighting the time values ​​between batches greater than the default value (in this example - 02:35 )




1- A fórmula em C6: =B6+$E$3
2- A fórmula em E6: =SE(D6>C6;RESTO(D6-C6;1);RESTO(C6-D6;1))

1- Formula in C6: =B6+$E$3
2- Formula in E6: =IF(D6>C6,MOD(D6-C6,1),MOD(C6-D6,1))


Como sempre, estou disponível para sugestões de melhoria e para ajudar nas questões que eventualmente estejam omissas, através dos comentários no blog ou por mail blog.excelcoisas@gmail.com
Espero que seja útil.


As always, I am available to suggestions for improvement and to help answer questions that are possibly missing through comments on the blog or via email blog.excelcoisas@gmail.com.
Hope that is useful.