Mensagens

A mostrar mensagens de 2012

EXCEL 2007 - GANTT TEMPLATE com Listview (with a Listview)

Imagem
Este gantt template tem um formulário que aparece automaticamente quando abrimos o ficheiro e que permite ver, mediante a escolha na combo, as tarefas que estão concluídas, expiradas ou em curso. Penso que é útil para quem tem de construir um plano com muitas tarefas.
This gantt template has a form that automatically appears when you open the file and you can view, by selection in the combobox, the tasks that are completed, expired or current. I think it is useful for anyone who has to build a plan with many tasks.






Além desta característica, este modelo tem outras possibilidades:
In addition to this feature, this model has other possibilities:


Permite ver, em simultâneo, os cenários de programação e de execução;
A legenda altera-se automaticamente, em função da escolha no tipo de gráfico;
Permite escolher a escala da linha de tempo;
Assinala no gráfico a data actual, sempre que a mesma coincide com as datas da linha de tempo.
Permite escolher a representação gráfica da percentagem de execução…

EXCEL 2007 - Como utilizar a função FREQUÊNCIA (How to use FREQUENCY Function)

Imagem
Como utilizar a função FREQUÊNCIA
Para se calcular o número de ocorrências de valores num conjunto de intervalos, usamos a função FREQUÊNCIA, que é uma função matriz. Como todas as funções deste tipo, A FREQUÊNCIA opera a partir de uma matriz de dados. Esta função, porém, precisa de outra variável: uma matriz de bins.
A matriz de dados é uma tabela de dados onde listamos os resultados pretendidos (ver Fig. A - DATABASE). A matriz de bins é a tabela de categorias ou de intervalos aos quais os resultados obtidos são associados (ver Fig. A - tabelas PESO e ALTURA).

EXCEL 2007 - SOMAR VALORES COM CRITÉRIOS MÚLTIPLOS (SUMIF WITH MULTIPLE CRITERIA)

Imagem
Na mensagem anterior apresentei um modelo de filtragem de dados com recurso a uma função UDF. Nesse mesmo modelo utilizei uma função para somar os valores constantes da tabela de acordo com vários critérios. Para executar este procedimento, existem várias alternativas utilizando as funções SOMARPRODUTO ou SOMA.SE.S: A célula com fundo rosa tem a seguinte fórmula: "=SOMARPRODUTO((BaseDados!$A$2:$A$5000=C$1)*(BaseDados!$C$2:$C$5000=$A4)*(BaseDados!$E$2:$E$5000))"A célula com fundo verde tem a seguinte fórmula: "=SOMARPRODUTO(--(BaseDados!$A$2:$A$5000=D$1);--(BaseDados!$C$2:$C$5000=$A5);--(BaseDados!$E$2:$E$5000))"Por fim, a célula com fundo laranja tem a fórmula: "=SOMA.SE.S(BaseDados!$E$2:$E$5000;BaseDados!$A$2:$A$5000;E$1;BaseDados!$C$2:$C$5000;$A6)". Todas estas possibilidades permitem chegar ao mesmo resultado. A diferença está apenas na rapidez de cálculo que o Excel executa. Ora, se em pequenas tabelas essa diferença é praticamente inexistente, já qua…

EXCEL 2007 - FILTRAR UMA BASE DE DADOS COM UMA FUNÇÃO UDF (How to filter a database with a UDF Function)

Imagem
O utilizador comum poderá pensar que filtrar ou analisar informação de uma pequena base de dados ou de uma tabela é algo para pessoas mais experimentadas em Excel. Ora bem, nem sempre é tão complicado assim, já que o poderemos fazer com recurso a uma função UDF (User Defined Function). Há algum tempo atrás, usei o modelo em anexo para filtrar dados de pequenas tabelas. A função utilizada permite listar os itens por ordem alfabética e acrescentar automaticamente outros itens, caso a base de dados ou a tabela seja modificada.
Common users may think that filtering or analyzing information from a small database or a data table is for people more experienced in Excel. Well, it's not always so complicated, since we can make use of a UDF (User Defined Function). For quite some time ago, I have used the template attached to filter data from small tables. This UDF example allows to list the items alphabetically and automatically add other items if the
database or table is modified.



Poder-se-…

EXCEL 2007 - DUAS ALTERNATIVAS À FUNÇÃO SE (Two Alternatives to IF Function)

Imagem
Aninhar uma função é usar a sua sintaxe como um dos argumentos de outra função. Veja-se o exemplo: = SE (A1 = "Maçãs"; 1; SE (A1 ="Laranjas"; 2; SE (A1 = "Pêras"; 3; SE (A1="Bananas"; 4)))) O Excel 2007 possibilita aninhar a função SE até 64 níveis. Uma enorme melhoria relativamente à versão anterior (Excel 2003) que só permitia 7 níveis. No entanto, uma fórmula com 64 condições torna-se muito extensa morosa na sua construção e a possibilidade de erro na sua elaboração exige atenção e constante verificação. Uma das alternativas para evitar esta situação é a utilização da função PROCV. Consideremos a tabela abaixo: To nesta IF function is to use its syntax as an argumentof another function.
Consider theexample:
= IF(A1="Apples", 1, IF (A1 ="Oranges", 2, IF (A1 = "Pears", 3, IF (A1 = "Bananas", 4))))
In Excel2007 its possibleto nestthe IF functionup to 64 levels. A hugeimprovement over theprevious version(Excel2003)th…