Mensagens

A mostrar mensagens de 2013

INSERIR CARIMBO DE TEMPO (Insert a Timestamp)

Imagem
Em virtude de ter recebido várias solicitações relacionadas com carimbos temporais, achei pertinente a publicação de um artigo sobre o assunto. Because having received several requests related to timestamps, I found relevant to submit a post with this the subject. Todos os dias temos necessidade de registar a data e/ou a hora actuais de um evento (agendamentos, registo de despesas, etc.). A estes registos chamam-se carimbos de tempo. Every day we need to record the date and/or time of a current event (scheduling, expense registration, etc.). To these records we call timestamps. Todavia, se tivermos de repetir o processo múltiplas vezes, torna-se aborrecido ter de reescrever constantemente a data e a hora. However, if we repeat the process multiple times, it becomes boring and time consuming having to constantly rewrite the date and time. Um modo de substituir a introdução manual data e/ou a hora actuais é utilizar as fórmulas HOJE() e AGORA(). A method of replacing the manual input of the cu…

OUTRO EXEMPLO DE CÁLCULO DE HORAS NEGATIVAS (Another Example for Calculating Negative Hours)

Imagem
Outra questão que me foi colocada recentemente relacionava-se com o cálculo de atrasos numa escala de produção. Neste caso específico, o atraso implicava que o resultado fosse negativo. E o Excel não reconhece directamente valores negativos quando se trata cálculo com unidades de tempo.
Another question I was asked recently was related to the calculation of delays on a production scale. In this particular case, the delay meant that the result was negative. And Excel does not directly recognize negative values ​​when it comes to calculation units of time.

A solução apresentada foi a seguinte:
My solution was as follows:


Fórmula da Célula E6 e seguintes:
= SE(D6>C6;RESTO(D6-C6;1);RESTO(C6-D6;1))
Formula in E6 and below:
= IF(D6>C6,MOD(D6-C6,1);MOD(C6-D6,1))
As células a vermelho realçam os casos em que o resultado é negativo e, por isso, existe um atraso  na escala.
Para que essas células apareçam com fundo vermelho, recorre-se à formatação condicional:
The red cells to enhance the cases in…

CALCULAR HORAS ENTRE DUAS DATAS COM UMA CONDIÇÃO (Calculate Hours Between Two Dates with a Condition)

Imagem
O cálculo com unidades de tempo (horas, dias, etc.) tem sido um dos temas mais recorrentes aqui no blog.

Há alguns dias atrás, puseram-me uma questão interessante. Tratava-se de calcular o número de horas entre duas datas, subtraindo um determinado conjunto de horas (16) a cada dia do intervalo, caso esse intervalo fosse superior a 24 horas.

Apresentei duas soluções para chegar ao mesmo resultado:

Na primeira, utilizei a função SE para criar um conjunto de condições (Tabela 1).
Na segunda, utilizei as funções DATADIF (que já foi objecto de um post - http://exceleoutrascoisas.blogspot.pt/search/label/DATADIF) e TEMPO.


Fórmulas da Tabela 1:
D4 =SE((C4-B4)*24<16;(C4-B4)*24;SE(E((C4-B4)*24>=16;(C4-B4)*24<=24);(C4-B4)*24-16;SE((C4-B4)*24>24;(C4-B4)*24-(ARRED((C4-B4)*24/24;0)*16)))))
- A formatação da célula é 0,00
E4 =(SE((C4-B4)*24<16;(C4-B4)*24;SE(E((C4-B4)*24>=16;(C4-B4)*24<=24);(C4-B4)*24-16;SE((C4-B4)*24>24;(C4-B4)*24-(ARRED((C4-B4)*24/24;0)*16)))))/24
- A formatação da…

CALCULAR HORAS EXTRA, TURNO NOCTURNO, HORAS NEGATIVAS, ETC (Overtime Calculation, Night Shift, Negative Hours, Etc.)

Imagem
Devido às inúmeras solicitações de ajuda, quer aqui no blog quer no meu dia-a-dia, em questões com cálculo de horas, criei um pequeno modelo de folha de ponto, focada no cálculo de horas extra e de turnos específicos.
É um modelo editável e facilmente adaptável à maioria das situações relacionadas profissionais.
Como sempre, estou disponível para sugestões de melhoria e para ajudar nas questões que eventualmente estejam omissas.
Espero que seja útil.
Due to numerous requests for help, either here on the blog or in my day-to-day issues in the calculation of hours, I have created a small timesheet template, focused on the calculation of overtime and specific shifts .It is an editable template and easily adaptable to most business situations.As always, I am available to suggestions for improvement and to help answer questions that may be missing.I hope you find it useful.


Baixar Modelo Download Template Informar se não conseguir baixar Please report if download link not work